Find answers, ask questions, and connect with our <br>community around the world.

Home Forums OpenFOAM Forum OpenFoam Installation error, ./Allwmake and Forgot Password

  • OpenFoam Installation error, ./Allwmake and Forgot Password

    Posted by Sidharth on September 22, 2023 at 5:11 am

    Dear Sir,

    As per the video (Installing OpenFoam part 2, time 5 minute), After clicking “./Allwmake”, I am getting the following error,

    /wmake/src/Allmake” 42:make:not found

    The foamsystemcheck command shows PASS.

    Also, Sir, I have forgotten my password. I tried resetting it using the reboot option by going into the grub menu but I cannot open it.

    I have tried clicking the “Shift+escape” key while restarting but the grub menu doesn’t open.

    Could you please help with these two errors? Thank you

    Sidharth replied 6 months, 4 weeks ago 3 Members · 8 Replies
  • 8 Replies
  • Rahul

    Member
    September 22, 2023 at 5:56 am

    Hi Sidharth,
    Are you using native Linux for the installation or using Virtual Box? If so are you familiar with working on Linux?
    If you would like to install OpenFOAM on Windows, you can use the Windows Subsystem for Linux, which will provide the same command line interface as Linux, but without the GUI. So you will be able to follow the same commands and follow the course. You can check the next part (Part 3) of the lecture to do this.
    Best regards
    Flowthermolab Support

    • Sidharth

      Member
      September 22, 2023 at 8:28 am

      Thanks for your prompt reply,

      I am using Oracle Virtual Box same as suggested in the previous video. I am new to Linux but I prefer to install OpenFOAM on Ubuntu. I have installed Virtual Box on my Windows 11 and I am able to start Ubuntu on the Virtual Box. Could you please help me install OpenFOAM on the virtual box?

      Also please comment on my query. Can I reset my password?

  • Rahul

    Member
    September 22, 2023 at 9:14 am

    Hi Sidharth,
    1. Regarding changing the administrator password, you can change it by entering the recovery mode for this. You can try pressing ‘Shift’ key while the Virtual machine is being booted to open the corresponding menu and check. Some solution for this have been discussed on the Ubuntu forums. Please go through those for detailed steps. But there may be some issue entering the boot options menu using Virtual Box. If you have installed Virtual Box only for OpenFOAM, you could maybe try to create a new OS in it.

    The reason we recommend using WSL over Virtual Box is that you can use the entire hardware resources like CPU and RAM for OpenFOAM using WSL. Whereas for VirtualBox, you can use only the resources specified for the virtual machine. Also WSL is basically the Linux OS in Windows without the GUI. So all OpenFOAM, coding etc can be run similar to how you would run on Linux. The only difference is that as there is no GUI, you will have to use ParaView GNU plot etc on Windows since they require a GUI.

    2. Regarding the error, it seems the ‘make’ utility has not been installed or there is some issue with its path. Can you please check the version of the ‘make’ utility using the command:
    make –version
    If make is already installed, please check the path(Generally in /usr/bin/make) using the command:
    which make

    If both these are showing valid results, please try to update the repository and install required dependencies using these commands:

    sudo apt-get update
    sudo apt-get install build-essential flex bison cmake zlib1g-dev libboost-system-dev libboost-thread-dev libopenmpi-dev openmpi-bin gnuplot libreadline-dev libncurses-dev libxt-dev
    sudo apt-get install qt4-dev-tools libqt4-dev libqt4-opengl-dev freeglut3-dev libqtwebkit-dev

    The issue may also be due to incompatibility between the OpenFOAM version being installed and the pre-requisites. Could you also mention which OpenFOAM version you are trying to install?

    Best regards

    Flowthermolab support

    • Sidharth

      Member
      September 22, 2023 at 2:23 pm

      Hello Rahul,

      Thanks. I was able to change the password.

      I am installing the OpenFOAM v2306 version. Now I am able to run the ./Allwmake command and the terminal shows the following,

      “Optional component (ADIOS2) has build issues.

      Openfoam will nonetheless remain largely functional.

      Done third party Allwmake

      Compile OpenFOAM libraries”

      While running this, I get the following line,

      “make” mpicc: No such file or directory

      PstreamGlobals.H:52:10:Fatal error:mpi.h: No such file or directory 52 | #include <mpi.h>

      Compilation terminated

      make” *** Error 1″

  • Rahul

    Member
    September 22, 2023 at 4:07 pm

    Hi Sidharth,

    It seems there is some issue with MPI library installation. I am not sure if it is an issue with installing on Virtual box. Could you please check if you have allocated more than 1 CPU core for the Virtual Machine?

    Also, please check if MPI has been installed using the command: ompi_info

    If it results in an error, you can try to install the mpi packages using:
    sudo apt-get install libcr-dev mpich2 mpich2-doc

    Could you please check the above things and update us?

    Best regards
    Flowthermolab support

    • Sidharth

      Member
      September 24, 2023 at 9:06 am

      Hii,

      I have allocated 4 CPU core processors for the virtual machine. MPI package was not installed but I installed it using the command that the terminal suggested

      “sudo apt install openmpi-bin”. Now the ompi-info works.

      The command that you suggested was giving some error.

      Now, I tried to redo the same commands for OpenFOAM installation using ./Allwmake but it again gave me the same error that I have written in my previous message.

      Also before ./Allwmake, I give the command line as “source etc/bashrc” which gives me the warning as

      “No completions for /home/Sidharth/Desktop/OpenFOAM/OpenFOAM-v2306/platforms/Linux64GccDPInt320pt/bin”

      [ignore if OpenFOAM is not yet compiled]”

      I have asked this on the mail where I was suggested to ignore this warning.

      • MIDHUN

        Member
        September 25, 2023 at 6:38 am

        Dear Sidharth,

        We can ignore error as its before compilation ,and once openfoam is fully compiled then when you give source etc/bashrc then it won’t show any warnings.

        For mpi related issues –

        sudo apt install libopenmpi-dev (please use this command and after installing rerun the ./Allwmake)

        You can use lscpu to get the information about number of cores that are used.

        Similarly run ./Allwmake -j 4 4 stands for number of cores for parallel compilation

        Regards

        M Midhun

        • Sidharth

          Member
          September 25, 2023 at 2:41 pm

          Thanks a lot, Midhun. I was able to install the OpenFOAM successfully.

          Also, in Quiz 2, even after typing the correct answer for the 5th question, it is showing incorrect to me.

Log in to reply.

error: Content is protected !!