Find answers, ask questions, and connect with our <br>community around the world.

Home Forums OpenFOAM Forum OpenFOAM installation

  • OpenFOAM installation

    Posted by Swapnil on January 9, 2024 at 1:37 am

    Hi I am getting this error message while sourcing bash files ” Warn: could not determine prefix for system-openmpi ”

    step 10 in OpenFOAM installation guide

    MIDHUN MURALI replied 4 months, 4 weeks ago 2 Members · 17 Replies
  • 17 Replies
  • MIDHUN MURALI

    Member
    January 9, 2024 at 7:29 am

    Hi Swapnil,

    Can you please share a screen shot of the error you are getting.

    Regards

    Flowthermolab Support Team

    • Swapnil

      Member
      January 9, 2024 at 9:24 am

      sure

  • MIDHUN MURALI

    Member
    January 9, 2024 at 1:53 pm

    Hi Swapnil,

    You can ignore this error and start compiling openfoam , so once openfoam is fully compiled then when you give source etc/bashrc then it won’t show any warnings.

    And we give ./Allwmake and start compiling there can be some errors this could be rectified by suitable dependencies . Incase you get any errors you can notify us will provide you suitable commands to fix it .

    Regards

    Flowthermolab Support Team

    • Swapnil

      Member
      January 9, 2024 at 3:41 pm

      Got it. Thanks

    • Swapnil

      Member
      January 9, 2024 at 5:01 pm

      HI I tried the ./Allwmake command but got the ” make not found error also ran foamInstallationTest which gives 2 fatal errors

  • MIDHUN MURALI

    Member
    January 10, 2024 at 5:48 am

    Hi ,

    It could be due to missing dependencies , you can use.

    sudo apt install make

    Then run ./Allwmake -j 3

    Like 3 indicates number of processors .There can be more errors as a result of missing dependencies you can let us know will help you out.

    Regards
    Flowthermolab Support Team

    • Swapnil

      Member
      January 10, 2024 at 6:06 pm

      Hello, I’ve followed all the mentioned steps, but I’m encountering an error even after executing the ./Alwmake command. Additionally, I’ve verified the OpenFOAM installation by running the foamInstallationTest command, which indicates two fatal errors.

  • MIDHUN MURALI

    Member
    January 11, 2024 at 5:50 am

    Hi,

    There can be these errors its due to missing dependencies so what you can do for resolving this error is

    sudo apt-get install gcc (for this issue)

    Then recompile ./Allwmake -j 4

    There can be more errors which can come please let us know will give suitble commands to install these dependencies.

    Regards

    Flowthermolab Support Team

    • Swapnil

      Member
      January 11, 2024 at 2:30 pm

      Hi, following the execution of the command mentioned earlier, the system check indicates a pass; however, the error 127 persists upon running the ./Allwmake command.

  • MIDHUN MURALI

    Member
    January 12, 2024 at 5:26 am

    Hi Swapnil,

    This is the issue with make g++ dependency you can resolve this by installing suitable dependencies.

    sudo apt-get install g++

    Then you can run ./Allwmake -j 4

    Regards

    Flowthermolab SupportTeam

    • Swapnil

      Member
      January 12, 2024 at 2:33 pm

      Hello, upon running the ./Allwmake command, I encountered a fatal error after which the compilation got terminated.

  • MIDHUN MURALI

    Member
    January 12, 2024 at 3:09 pm

    Hi Swapnil,

    sudo apt install libopenmpi-dev

    Please use this command for installing the dependency and then recompile using ./Allwmake .


    Regards

    Flowthermolab SupportTeam

    • Swapnil

      Member
      January 12, 2024 at 3:47 pm

      Hi, I implemented the changes as mentioned above, but this time the compilation concluded with a 127 error.

      • Swapnil

        Member
        January 15, 2024 at 2:36 am

        Hi, ignore the previous query got it resolved by installing flex dependency. Can you help me with these new compilation errors after executing the ./Allwmake command.

        • MIDHUN MURALI

          Member
          January 15, 2024 at 8:25 am

          Hi Swapnil,

          Can you please check like something missing should be shown i think probably it could be due to fftw

          in that case please use these commands

          sudo apt-get install fftw-dev

          First you can try with this then run ./Allwmake in case its not working out you can use

          apt-get install libfftw3-dev libscotch-dev libptscotch-dev libboost-system-dev libboost-thread-dev libcgal-dev

          Then run ./Allwmake again.

          Regards

          Fllowthermolab SupportTeam

          • Swapnil

            Member
            January 15, 2024 at 10:13 am

            Hi, I tried with sudo apt-get install fftw-dev but it resulted in the same error after executing ./Allwmake command. after executing the second command you mentioned in your last reply I m getting this message on terminal.

            • MIDHUN MURALI

              Member
              January 15, 2024 at 12:55 pm

              Hi,

              sudo apt-get install libfftw3-dev libscotch-dev libptscotch-dev libboost-system-dev libboost-thread-dev libcgal-dev

              You can include sudo in the beginning and try the same , If its not getting resolved we will check over a zoom call in for that please write to support@flowthermolab.com to raise a support ticket.

              Regards

              Flowthermolab SupportTeam

Log in to reply.

error: Content is protected !!