Find answers, ask questions, and connect with our <br>community around the world.

Home Forums OpenFOAM Forum OpenFOAM Installation

  • OpenFOAM Installation

    Posted by Alagappan Chidambaram on July 3, 2022 at 3:35 pm


    While trying to compile OpenFOAM by running Allwmake file by running the command ./Allwmake I get an error saying Make file not available. I am not sure what to do now. Can you help me out?

    Alagappan Chidambaram replied 1 year, 8 months ago 4 Members · 4 Replies
  • 4 Replies
  • Alagappan Chidambaram

    July 3, 2022 at 4:34 pm

    This the error I am getting –

    alagappan@Alagappan-VirtualBox:~/OpenFOAM/OpenFOAM-v2206$ ./Allwmake


    2022-07-03 12:32:11 -0400
    Starting compile OpenFOAM-v2206 Allwmake
    Gcc system compiler []
    linux64GccDPInt32Opt, with SYSTEMOPENMPI sys-openmpi

    /home/alagappan/OpenFOAM/OpenFOAM-v2206/wmake/src/Allmake: 42: make: not found
    alagappan@Alagappan-VirtualBox:~/OpenFOAM/OpenFOAM-v2206$ sudo apt install wmake
    [sudo] password for alagappan:
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    E: Unable to locate package wmake

  • Dabbiru Sai Vivek

    October 12, 2022 at 5:23 pm

    I am trying to install OpenFOAM on an Ubuntu system run on a live USB. On running source etc/bashrc, I got the following:

    aefnjhaf@45879523:~/OpenFOAM/OpenFOAM-v2206$ source etc/bashrc
    Warn: could not determine prefix for system-openmpi
    No completions for /home/aefnjhaf/OpenFOAM/OpenFOAM-v2206/platforms/linux64GccDPInt32Opt/bin
    [ignore if OpenFOAM is not yet compiled]

    I had got the “Make file not available.” error as mentioned by Alagappan on running ./Allwmake. I then tried sudo apt install make and got the following:

    aefnjhaf@45879523:~/OpenFOAM/OpenFOAM-v2206$ sudo apt install make
    [sudo] password for aefnjhaf: 
    Reading package lists... Done
    Building dependency tree... Done
    Reading state information... Done
    make is already the newest version (4.3-4.1build1).
    The following packages were automatically installed and are no longer required:
      chromium-codecs-ffmpeg-extra gstreamer1.0-vaapi i965-va-driver intel-media-va-driver libaacs0 libaom3 libass9 libavcodec58 libavformat58
      libavutil56 libbdplus0 libblas3 libbluray2 libbs2b0 libchromaprint1 libcodec2-1.0 libdav1d5 libflite1 libgme0 libgsm1
      libgstreamer-plugins-bad1.0-0 libigdgmm12 liblilv-0-0 libmfx1 libmysofa1 libnorm1 libopenmpt0 libpgm-5.3-0 libpostproc55 librabbitmq4
      librubberband2 libserd-0-0 libshine3 libsnappy1v5 libsord-0-0 libsratom-0-0 libsrt1.4-gnutls libssh-gcrypt-4 libswresample3 libswscale5
      libudfread0 libva-drm2 libva-wayland2 libva-x11-2 libva2 libvdpau1 libvidstab1.1 libx265-199 libxvidcore4 libzimg2 libzmq5 libzvbi-common libzvbi0
      mesa-va-drivers mesa-vdpau-drivers pocketsphinx-en-us va-driver-all vdpau-driver-all
    Use 'sudo apt autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    Further, I have tried find /home/aefnjhaf/OpenFOAM/OpenFOAM-v2206 -type f -iname make and the computer isn’t able to find anything for that.

    Previously, when I had tried the wmake -j command as per instructions, I had got the following:

    aefnjhaf@45879523:~/OpenFOAM/OpenFOAM-v2206$ wmake -j
    Compiling enabled on 4 cores
    wmake: 'Make' directory does not exist in /home/aefnjhaf/OpenFOAM/OpenFOAM-v2206
        Searching up directories tree for Make directory
    Error: no Make directory for /home/aefnjhaf/OpenFOAM/OpenFOAM-v2206

    However, running find /home/aefnjhaf/OpenFOAM/OpenFOAM-v2206 -type d -iname make gets me lot of directories titled ‘Make’ in various directories present in OpenFOAM-v2206 directory.

    Running make -version gives me:

    GNU Make 4.3
    Built for x86_64-pc-linux-gnu
    Copyright (C) 1988-2020 Free Software Foundation, Inc.
    License GPLv3+: GNU GPL version 3 or later <>
    This is free software: you are free to change and redistribute it.
    There is NO WARRANTY, to the extent permitted by law.

    Kindly advise me as to what can be done to remedy this problem.

Log in to reply.

error: Content is protected !!