Find answers, ask questions, and connect with our <br>community around the world.

Home Forums OpenFOAM Forum Mesh recreation

  • Mesh recreation

    Posted by umara on February 6, 2024 at 8:31 am

    i have polymesh file and i want to recreate the mesh on Openfoam v11 version. but fail to do so. any suggestion.

    umara replied 1 month, 1 week ago 2 Members · 13 Replies
  • 13 Replies
  • Barış Bicer

    Moderator
    February 7, 2024 at 9:28 pm

    Hi Umara,

    You made me a bit confused.

    First tell me how did you create your available polyMesh?

    IF you have polyMEsh folder why do you try to re-create mesh? if you wanna create new mesh then you should delete polyMesh folder.

    Please give more info.

    Thanks

    Baris

    • umara

      Member
      February 12, 2024 at 6:56 am

      Hello i meant i deleted the polymesh folder in constant and tried to recreate the mesh but it doesnt create and if i keep the polymesh folder and give checkMesh command so that i cant save mesh as touch.foam command. it gives error as well.

    • umara

      Member
      February 12, 2024 at 7:06 am

      So when i try to run in parallel i get following error

  • Barış Bicer

    Moderator
    February 12, 2024 at 11:31 pm

    which tutorial case do you try to solve?

    It seems like you dont have proper mesh. if you have mesh can you paste here checkMesh results.

    • umara

      Member
      February 19, 2024 at 12:11 pm

      hello,

      it is not a tutorial case it is another case. seems like i have some issues with mprin following message i get on logfoamrun

  • Barış Bicer

    Moderator
    February 25, 2024 at 9:49 pm

    can you send me all the contents of folder especially the folders inside constant folder?

    And then show me your comment and its completed log file? then I can help you.

    Fyi.

    Baris

    • umara

      Member
      March 8, 2024 at 8:22 am

      hello Baris,

      can we have a 30 min meeting to over case file quickly. The files are difficult to send by email.

      • Barış Bicer

        Moderator
        March 9, 2024 at 9:20 am

        Hİ Umara,

        It will be difficult to catch a time due to time difference and my busy schedule.

        Therefore, please go step by step.

        1. Post your case folder content here. I wanna see which folders do you have under your case folder?

        2. Paste here which files do you have under of your constant/polyMesh folder?

        3. How did you create your mesh? Put here the checkMesh results.

        4. If everything is fine tell me what do you try to solve and which solver do you use?

        5. Dont run case parallel. To understand where the problem comes first run the case serial and paste here log file.

        IF you can address these each step we may catch the problem.

        Fyi.

        Best

        Baris

        • umara

          Member
          March 11, 2024 at 7:04 am

          Hello

          As i mentioned this is my own case no taken from tutorials. attached the content of case folders. The simulation stops at 6 sec and result seem to be weird. Could you please have a look and let me know what im doing wrong here

  • Barış Bicer

    Moderator
    March 11, 2024 at 12:54 pm

    Hi,

    There are many unclear things here :

    1. I never heard such a solver name “incompressibleFluid”? Did you modified any solver? Then case is totally unclear bcs ı dont know what he have done?

    2. The flow looks so slow since you assigned 0.004 m/s? Then case is high viscous flow?

    3. if you assing fixed vel. at the inlet you should assign fixed pressure at the outlet. But I see that you have done reverse?

    • umara

      Member
      March 14, 2024 at 7:19 am

      The case is viscous fluid (that is oil) is flowing from inlet to outlet. No heat transfer just viscous model k-epsilon. i have pressure inlet (known) and pressure outlet condition (unknown). for oil i have its density and viscosity value. on fluent the model is simply set up but when i try to set it up on openfoam i get some issues

    • umara

      Member
      March 14, 2024 at 7:20 am

      the flow i think i dont need to provide if i give pressure value at inlet. no velocity value at inlet. i just want to calculate pressure difference value at outlet. it seem simple flow case on fluent but on openfoam im guessing im making some mistakes.

      • This reply was modified 1 month, 1 week ago by  umara khan.
    • umara

      Member
      March 14, 2024 at 10:46 am

      Case description

Log in to reply.

error: Content is protected !!