Find answers, ask questions, and connect with our <br>community around the world.

Home Forums OpenFOAM Forum DPM spray simulation crash

  • DPM spray simulation crash

    Posted by Harshavardhan on November 8, 2022 at 8:49 am

    Hi,
    I am running a multiphase simulation. I am injecting a water droplets through hollow cone injection and running it in transient methods. Whenever I run my simulation, after 1second I get the following error in Open foam, if any one could help me will be really helpful.

    Loading requirement: openmpi/4.1.2
    /local/spool/pbs/mom_priv/jobs/62955792.gadi-pbs.SC: line 11: cd: /scratch/hy4/hk3956/1sec: No such file or directory
    [2] #0 Foam::error: rintStack(Foam::Ostream&) at ??:?
    [2] #1 Foam::sigFpe::sigHandler(int) at ??:?
    [2] #2 ? in /lib64/libpthread.so.0
    [2] #3 Foam::scalarProduct<double, double>::type Foam::sumProd<double>(Foam::UList<double> const&, Foam::UList<double>$[2] #4 Foam::PBiCGStab::scalarSolve(Foam::Field<double>&, Foam::Field<double> const&, unsigned char) const at ??:?
    [2] #5 Foam::PBiCGStab::solve(Foam::Field<double>&, Foam::Field<double> const&, unsigned char) const at ??:?
    [2] #6 Foam::fvMatrix<double>::solveSegregated(Foam::dict ionary const&) at ??:?
    [2] #7 Foam::fvMatrix<double>::solveSegregatedOrCoupled(F oam::dictionary const&) at ??:?
    [2] #8 Foam::fvMesh::solve(Foam::fvMatrix<double>&, Foam::dictionary const&) const at ??:?
    [2] #9 Foam::SolverPerformance<double> Foam::solve<double>(Foam::tmp<Foam::fvMatrix<doubl e> > const&) at ??:?
    [2] #10 Foam::LESModels::dynamicKEqn<Foam::EddyDiffusivity <Foam::ThermalDiffusivity<Foam::CompressibleTurbul enceModel<$[2] #11 ? at ??:?
    [2] #12 __libc_start_main in /lib64/libc.so.6
    [2] #13 ? at ??:?
    [gadi-cpu-clx-1368:2539384:0:2539384] Caught signal 8 (Floating point exception: tkill(2) or tgkill(2))
    ==== backtrace (tid:2539384) ====
    0 0x0000000000012ce0 __funlockfile() :0
    1 0x0000000000012b7f gsignal() :0
    2 0x0000000000012ce0 __funlockfile() :0
    3 0x00000000008941de Foam::sumProd<double>() ???:0
    4 0x00000000006b5fe3 Foam::PBiCGStab::scalarSolve() ???:0
    5 0x00000000006b79c2 Foam::PBiCGStab::solve() ???:0
    6 0x00000000010a0b55 Foam::fvMatrix<double>::solveSegregated() ???:0
    7 0x000000000098b1a8 Foam::fvMatrix<double>::solveSegregatedOrCoupled() ???:0
    8 0x0000000000933b3f Foam::fvMesh::solve() ???:0
    9 0x000000000013c0cb Foam::solve<double>() ???:0
    10 0x000000000021039d Foam::LESModels::dynamicKEqn<Foam::EddyDiffusivity <Foam::ThermalDiffusivity<Foam::CompressibleTur$ 11 0x000000000044c8a7 main() ???:0
    12 0x000000000003acf3 __libc_start_main() ???:0
    13 0x000000000044de9e _start() ???:0
    =================================
    ————————————————————————–
    Primary job terminated normally, but 1 process returned
    a non-zero exit code. Per user-direction, the job has been aborted.
    ————————————————————————–
    ————————————————————————–
    mpirun noticed that process rank 2 with PID 0 on node gadi-cpu-clx-1368 exited on signal 8 (Floating point exception).
    ————————————————————————–
    [gadi-cpu-clx-1368:2553552] *** An error occurred in MPI_Recv
    [gadi-cpu-clx-1368:2553552] *** reported by process [703004673,8]
    [gadi-cpu-clx-1368:2553552] *** on communicator MPI_COMM_WORLD
    [gadi-cpu-clx-1368:2553552] *** MPI_ERR_TRUNCATE: message truncated

    Barış Bicer replied 1 year, 5 months ago 2 Members · 2 Replies
  • 2 Replies
  • Barış Bicer

    Moderator
    November 14, 2022 at 4:41 pm

    Hi,

    Truely speaking I dont have DPM experience, however when I look at the error it looks something is wrong with your initial & boundary conditions!

    You are runing LES without any initialization? what is your time step? your mesh is compatible with your time step?

    Did you try to run as laminar first?

     

     

  • Barış Bicer

    Moderator
    November 14, 2022 at 4:41 pm

    Hi,

    Truely speaking I dont have DPM experience, however when I look at the error it looks something is wrong with your initial & boundary conditions!

    You are runing LES without any initialization? what is your time step? your mesh is compatible with your time step?

    Did you try to run as laminar first?

     

     

Log in to reply.

error: Content is protected !!