Find answers, ask questions, and connect with our <br>community around the world.

Home Forums OpenFOAM Forum blockMesh utility error

  • blockMesh utility error

    Posted by Rituraj on July 5, 2023 at 4:23 pm

    Dear OpenFoamSupport,
    I tried to run the blockMesh command for the lid-driven cavity case. As you can see I am in my ‘run’ directory and specifically in the ‘system directory’ within the cavity case file. When I tried to execute the ‘blockMesh’ command, I got the following error:

    FOAM FATAL ERROR: (openfoam-2212)
    cannot find file “/home/ritu/OpenFOAM/ritu-v2212/run/cavity/system/system/controlDict”
    Please help! Thank you very much!
    (I can see the controlDict file within the ‘system’ directory, but still the above error says cannot find file)

    Barış Bicer replied 9 months, 2 weeks ago 2 Members · 2 Replies
  • 2 Replies
  • Rituraj

    Member
    July 5, 2023 at 5:21 pm

    Dear support,

    I think I have found the solution. So, I was running the blockMesh command from the ‘system’ directory. I came back to the ‘cavity’ directory and ran it. Then it worked. I wonder why. Because when I am in the ‘system’ directory, I have direct ‘access’ to the controlDict file.

  • Barış Bicer

    Moderator
    July 6, 2023 at 3:24 pm

    yeah Borah good to know that you solved.

    Best

Log in to reply.

error: Content is protected !!