Find answers, ask questions, and connect with our <br>community around the world.

Home Forums OpenFOAM Forum Aliases gone after installing zsh- how to repair?

  • Aliases gone after installing zsh- how to repair?

    Posted by John on August 16, 2023 at 10:45 pm

     

    Ask your questions here. Try to elaborate
    I recently installed zsh in order to customize the look of my terminal window. Now as I follow along (actually I’m in Lesson 9) some commands don’t seem to work. I think this has to do with aliases, but I don’t see how those are changed as I look back. Some examples from my terminal follow:

    ~ pwd at 10:41:39 AM
    /home/johnscoffee
    ~ cat $WM_PROJECT_DIR/etc/config.sh/aliases 1 х at 11:17:23 AM
    cat: /etc/config.sh/aliases: No such file or directory
    ~/OpenFOAM/johnscoffee-v2212/run cp -r $FOAM_TUTORIALS/incompressible/icoFoam/elbow . 1 х at 01:47:40 PM
    cp: cannot stat ‘/incompressible/icoFoam/elbow’: No such file or directory

    ~ run at 10:50:35 AM
    zsh: command not found: run

    Barış Bicer replied 7 months, 3 weeks ago 2 Members · 3 Replies
  • 3 Replies
  • Barış Bicer

    Moderator
    August 18, 2023 at 8:32 am

    Hi,

    Actually I dont know what happened exactly. However, as far as I understood that this problem happened after your installation .zsh program. Uninstall it and try again.

  • John

    Member
    August 26, 2023 at 12:15 am

    I tried uninstalling zsh but I’m still getting behaviour that indicates its there.  How to wipe my WSL system clean and start it all over?

  • Barış Bicer

    Moderator
    August 26, 2023 at 1:34 pm

    I am sorry but this is not related to OpenFOAM topic and I dont know what you tried to do exactly. Just remove .wsl and install it again that may lead to solve problem.

Log in to reply.

error: Content is protected !!